Questions? Feedback? powered by Olark live chat software

Which Website Browser Is Best?

The Zeald Website Management software works well on most major web browsers.  However, it works best with the web browser Google Chrome. You can browse faster, more safely and more efficiently with Google Chrome than any other website browser out there. If you would like to try out ‘Chrome’, you can download it for free by going here:
https://www.google.com/intl/en/chrome/.

If you are unable to use Chrome, and are editing the website using Internet Explorer we encourage you to use the latest version which is currently Version 11.

A lot of people will be viewing your website using Internet Explorer or Mozilla Firefox so we recommend you check the look of your website using these browsers and it is also very useful to use Internet Explorer when testing your website to purchase or to login as one of your customers or members.
 

Why don't we support all the browsers?

 

Progressive enhancement


We follow a browser support policy known as "Progressive enhancement".  This means that while users with extremely old or extremely weak browsers should be able to see the content of your site, that doesn't mean we shouldn't use modern browser features like CSS3, HTML5 that are only supported in the newest versions of browsers.  

This is explained in detail in our "Browser support policy"

Means we have more time to spend working on other great features to improve your website
It takes a lot of time for our R&D team to develop, test and bug fix new features and upgrades to get  them to work in older browsers. As Zeald clients you pay for this time and resource with your monthly hosting. By not supporting older browsers, our development team have so much more time to spend adding other great new features to your website....and we have a big list of future features

Means Website manager will run faster
Features like drag drop uploads, interface styles, graphs etc, can be heaps faster without all the code required to make these features work on older browsers